Discuss Intellivision, Atari, Colecovision, Nintendo, and More!
Welcome to the IntellivisionRevolution Forums!
Discuss Intellivision, Atari, Colecovision, Nintendo, and More!

Have You Played Your Intellivision Today?

Log in

I forgot my password



Social bookmarking
Social bookmarking digg  Social bookmarking delicious  Social bookmarking reddit  Social bookmarking stumbleupon  Social bookmarking slashdot  Social bookmarking yahoo  Social bookmarking google  Social bookmarking blogmarks  Social bookmarking live      




Bookmark and share the address of Discuss Intellivision, Atari, Colecovision, Nintendo, and More! on your social bookmarking website

RSS feeds

Yahoo! 
MSN 
AOL 
Netvibes 
Bloglines 


The Intellivision Forums
Who is online?
In total there are 7 users online :: 1 Registered, 0 Hidden and 6 Guests

Steve Jones

[ View the whole list ]


Most users ever online was 189 on Sun 22 Sep 2013, 8:05 am

You are not connected. Please login or register

Discuss Intellivision, Atari, Colecovision, Nintendo, and More! » The Intellivision Section » The Intellivision Forum » Playcable missing chip?

Playcable missing chip?

Go down  Message [Page 1 of 1]

1 Playcable missing chip? on Sat 23 Sep 2017, 10:26 am

MonsterSky

avatar
Janitor
Janitor
I have a big doubt looking inside my Playcable. There is a red empty socket (sorrounded by a red rectangle in the picture), is there any missing chip? I never plugged it into my Inty, I want to be sure that there is nothing missing.

It seems that the MCM411XXXXX chips are RAM, the the empty socket could be firmware?

Thank you for you help. Smile
Attachments
21762716_520966184913740_7230997538003188552_o.jpg
You don't have permission to download attachments.
(42 Kb) Downloaded 8 times

2 Re: Playcable missing chip? on Wed 02 May 2018, 4:55 am

mrme


Rookie
Rookie
I'd say it's a general instrument rom chip, 40 pin, 10 bit similar to the exec chip. It would have the code to build the titlescreen and menu. I think it would also handle the address and bus decoding for the ram chips. My guess is that if you pluggd this into an Intellivision you would get a black screen. If it were complete I think you would get a standard exec titlescreen and nothing more.

Are there five mcm4116 ram chips? That would be 80k bits or 8k x 10 bits.

3 Re: Playcable missing chip? on Wed 02 May 2018, 4:34 pm

Intymike

avatar
Janitor
Janitor
With or without the chip. The Playcable is without use nowadays.

4 Re: Playcable missing chip? on Fri 04 May 2018, 6:23 am

mrme


Rookie
Rookie
You should plug it in and see what it does; we could be wrong about the rom chip. I think most of the code for building the menu and the music is downloaded anyway.

I'm not much of a collector, would a collector pay more for one that produces the initital titlescreen over one that doesn't.

5 Re: Playcable missing chip? on Sat 05 May 2018, 12:41 pm

MonsterSky

avatar
Janitor
Janitor
mrme wrote:My guess is that if you pluggd this into an Intellivision you would get a black screen.
Yes, blank screen, the missing chip is the main controller.

mrme wrote:
Are there five mcm4116 ram chips? That would be 80k bits or 8k x 10 bits.
Yes, there are.

Sponsored content


Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum